App not working

Hey Everyone, since a time i cant use Infinite Flight anymore, when i try to open the App it just closes directly, does anyone know how to fix it?

Phone: Honor Play

1 Like

I also tried to reinstall the app

Check your storage. Is it nearly full?

Alright, try this.

  • Restart your phone. This helps a lot.
  • Delete and reinstall Infinite Flight.

Lastly, if your storage it full or getting full clear a bunch of it. IF needs a lot of space to run.

kind of like google @Levet

If those fail, contact the staff team.

Storage is not full, still over 50GB and restarted often

Do you know the exact specs for your device and is your operating system up-to-date?

Updated Recommendation:
Follow these steps in this specific order @Finn_Kumer

  • Uninstall the app
  • Restart the device
  • Reinstall from Play Store.
1 Like

Did all Steps.
Kirin 970 & ARM Mali-G72 MP12
4GB Ram
64GB Space

Would clearing the cache work?

When you open Infinite Flight, do you see in the information bar “Navigation Database Updating…60%” and then the app crashes?

You’ll see this at the bottom of your screen.

In this case we had the author delete IF and reinstall so it should be a fresh start. Also, if the app is crashing before getting to the home screen, clearing cache isn’t an option at this time.

1 Like

No, when I open it I see Blackscreen for a second then crash

Okay thanks for the response. I know that this may seem redundant but can you go ahead and close all of your apps including Infinite Flight, power down your device and then try again?

If that doesn’t resolve your issue do the following: Confirm that you have the latest Operating System installed (you are probably on Oreo if you don’t have Pie).

Although it may be difficult for us to figure out what may have changed in your case to make this crash occur, these are some steps that have helped users in the past.

My honor play works fine with the app so you must just be unlucky.

Still not working, I have Android 9.1

Can you do the following:

  • Go to settings
  • Go to apps
  • Find Infinite Flight
  • Select “Advanced”
  • Scroll all the way to the bottom and take a screen shot

Have you updated your OS? I see you have 9.1, and the current OS version of Android is 10.0. Can you access your settings and see if your OS is up to date?

There will be no Android 10 for Honor Play said Huawei

There is no Advanced Option


Are you sure you reinstalled? I’m asking since your screenshot is showing the app using 2.71GB storage and no usage for the past 3 hours. The app itself doesn’t use more than 30MB after being freshly installed.

It is vital that you follow the steps previously provided or it will be very difficult to assist I’m afraid.


I reinstalled now, I thought I did but now it says 40mb (I set my phone to German)
It still closes directly