App not deleting on iOS

Just downloaded new update but after that it remained like this for hours ( image 1 ) I tried to delete it so o can reinstall it but it won’t budge and now I can’t one it or delete it :’’( image

Device specifications :

iPhone 5s
iOS version: 9.3.2 (13F69)

Tried to download other apps and they are running smoothly Uploading…

Try pausing it then resuming the downloading

Sounds like there are bugs everywhere… But not to worry, they should fix themselves or something is going wrong with your device. I’m not an expert in this so we should ask someone who has experienced this.

Usually in cases like these we call an exterminator. I think he’s here already

I can’t do anything with the icon, it doesn’t shows any option to pause it or delete it

Try going through the App Store

It is showing open icon but app is not lunching

Your best bet then is to restart your phone as see if that works. If not, then I have nothing else for you

This has happened to me
Try Settings>Restrictions>InstallingApps>Off
Restart the phone then take that setting off and try to reinstall

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.