App not compatible with this IPad

So I went to install the new update, but a box came up saying that the update was not compatible with this iPad. I have an IPad 2. Help?

Unfortunately your device doesn’t fit the device requirement parameters.

2 Likes

So I cannot use the update, I have to buy a newer iPad to be able to install it?

https://developer.apple.com/library/content/documentation/DeviceInformation/Reference/iOSDeviceCompatibility/HardwareGPUInformation/HardwareGPUInformation.html#//apple_ref/doc/uid/TP40013599-CH106-SW1

Please see the list of approved devices. We apologize for the inconvenience but unfortunately the Infinite Flight Team has to tailor the Global Update as best as they could trying to include as many devices possible to support the new update.

Kind Regards,
Chris

2 Likes

yes my iPad can just run Infinite’s flight

1 Like