App/Flight Crashes on entry

The App Crashes as soon as entering the Flight, when “Automatic Engine Start” is disabled (systems off when spawning). This only happens on planes with Jet-Engines, not on Turboprops. Tested on different Android Versions and devices getting similar results.

Devices: Huawei Media Pad M5, Xiaomi Pad 5, Nothing Phone 2
Operating systems: Android 9 (EMUI 9.1.0), Android 13 (MIUI 13.0.6), Android 14 (Nothing OS 2.5.2)

To Replicate: Disable “Automatic Engine Start” and Start any Flight with an A320 or similar.
Things I’ve tried so far to resolve:

  • Restart App/Phone
  • Clearing Cache (in-app/via device settings)
  • Deleting all app-data
  • Uninstalling/Reinstalling

Hopefully its just something on my end :D
Thanks!

1 Like

This is happening with me too!

Thanks for letting us know, sorry you are having this issue. Seems to be isolated to Android for now

We are looking into it

Is it happening on all of your devices after a reinstall? just wanted to check

1 Like

Just to add im on S22, I dont think this was happening before I deleted the app, but when I reinstalled it started happening

1 Like

Hi, thanks for looking into it. Sadly yes, happening on all three of my “testing devices”. Also forgot to mention, I left all other settings in default to not distort the result.

1 Like

Thanks for that info! We’ll have a look, it might need a hotfix. Hang tight and I will let you know when I have more info.

@IF-GER-SPEC-Calvin @Novak_Jakovljevic

3 Likes

Thank you!

I am able to repro.

As a workaround, keep Automatic Engine Start checked.

2 Likes

While yes this is true not to crash the sim, many people want to fly realistically at time which is with engines off at start.

We just have to wait for a hotfix😁

Just turn off the engines after spawning. :)

True but still unrealistic, but it is the only option for now until the devs find a fix, ill just wait it out

Additional thing I just discovered and I guess at least could be related:

After starting the flight with “Automatic Engine start” enabled and loading in, bringing the plane manually in the cold and dark config (as the workaround for not starting off), the game crashes around 10 seconds after shutting everything off.

To replicate: start Flight with configured plane (automatic engine start enabled) and start shutting things off. After everything has been turned off (All Engines, Nav and Beacon lights) wait (for me) around 10 seconds.

It the “main battery” does not seem to have any influence, as well as which camera position is chosen.

2 Likes

It’s a workaround so that you will be able to fly.
If you rather not fly until it is fixed, that is totally up to you. :)

2 Likes

It happens to me too cam

Device: realme 10
Op: android 14

I reinstalled IF 2 times but nothing changed
I use Xiaomi Poco F3 Android 11 MiUI 12.5

We’re working on a fix and will let you know when it’s available. Really sorry about this

1 Like

A fix is now available!

Please try it and let us know if it works:

5 Likes

I am Japanese and my English is not good, so I will tell you in Japanese.Please confirm in translation.

上記にある対策 端末の再起動、キャッシュの削除、アプリの再インストール、端末のアップデート(Android)が最新になっているかの確認をしましたが解消には至っておりません。

Terminals in use

XPERIA PRO-i
XQ-BE42

Android Ver.13

Hello!

Have you tried installing 24.2.1? It released under an hour ago

直りました!!対応して頂きありがとうございました!!

Thanks for your response!!