App Crashing on Replay Mode

I have just completed a short flight with the Xcub and wanted to go into replay mode to take some shots. As I enter the replay mode section and click the file, it goes onto the loading screen but then the app crashes. I don’t know if anyone else is facing this issue but I certainly am! The device I’m using is an IPhone X (running iOS 13)

Steps taken that lead up to the app crashing:

  1. End current Flight and find myself on the home screen
  2. I click replay mode and select the flight I want to load
  3. I select the file and it goes onto the loading screen. The file briefly loads for a few seconds and then app crashes
1 Like

Let me try running it on my iPad, I will reply to this thread if anything wrong happens.

Update
I run well on my iPad 6th generation and nothing seems to be an issue. I believe iOS 13 beta might just be the issue. I will move this to PMs as this will go off topic shortly discussing about phone’s software updates.

1 Like

Before you do that, I’ll try flying another aircraft and see if I can get into replay mode, just to see if this issue is only related to the Xcub

Just tried on the iPhone X. No issues so far.

Can you try the classic troubleshooting solutions?

  • Restart phone
  • Restart app
  • Reinstall app
  • Update iOS to 12.3.1
1 Like

I’ll give those a go. Replay mode was working before this update came out. I’ll update this thread once I’ve done the following you’ve mentioned above.

1 Like

Take your time! We are always here to help!

1 Like

Perfect. If you could try to include the exact steps you take to make it crash, that would be great. Even if they are simple and obvious, it helps us to have all the details. We also. We also need the replay.

3 Likes

Just happened to check for software updates and you guys were right! There is a new iOS 13.3.3 update and that could be the problem! Wouldn’t have known about it had you guys not told me

1 Like

I’ve included the steps above and should I also try and see if I can get a screenshot?

We’d need the replay.

I should have probably clarified it a bit better. What I meant to say is that the app crashes just as the replay loads. The replay briefly loads and pops up but before I can do anything, the app shuts. I hope I’m not misunderstanding you.

  1. Have you tried the steps I’ve mentioned above?
  2. Have you tried a different replay and seeing if the issue is still there?
1 Like

Did you install the iOS update if you had one? This could just be iOS 13 since its in a beta.

1 Like

Update: I’ve restarted my phone, restarted the app, deleted and reinstalled the app, and also updated my iOS to the latest build and the issue still persists unfortunately

Can you export the replay you are trying to load?

1 Like

Could you enlighten me on how I can do that?

Go to the replay screen
Select the replay you want to export
Press Share
It will prompt you for a location to save it.

1 Like

Alright I’ve done that and have already saved it but can’t seem to upload it here as it’s not the correct file type

To upload it, follow the instructions on this website: https://sharemyinfiniteflight.com/

1 Like

Here’s the Replay