App crashing during long hauls

Hi,

So, full disclosure, I have an Honor 9 phone which handles Infinite Flight spectacularly with all settings to high (except anti-aliasing, which I keep off). While flying, I have 2.5 GB RAM free at all times, and I have more than enough storage on the phone.

I’ve done long haul flights before, and my device has always handled them well. However, since Tuesday night, I’ve tried the VIDP - LFPG three times in a Boeing 777-300ER with the same flight plan. Each time, the app kicks me out soon after the 5hr mark. After the first time, I tested the second and third time with all settings turned down to low, but it still didn’t help. Rebooting the device, and uninstalling/reinstalling also didn’t help.

I find this so weird, because it’s definitely not an issue of lack of resources.

The weird thing is first flight I was flying at 0.80M at FL320 and the app crashed around 5hrs43mns in. The second and third time, I was flying at 0.85M at FL320 and the app crashed around 5hrs 10mns both times, give or take a few mins. This indicates to me that the determining factor did not seem to be the time flown, but rather the distance flown, given that all three times I would have approximately covered the same distance (given the slower speed in the first flight).

I’m sure this is a bug somehow, even because the app doesn’t “crash” in the traditional manner, but seemingly closes. It’s quite hard to explain. And as I said, it’s certainly not a resources issue

Does anyone have any idea how I can get around this?

2 Likes

Hello!
Just some things i’ve thought about.

  • Does your phone overheat, if so, turn your brightness down in flight and power savings mode on.
  • clear Cache
    This is all i really know, sorry.
    Best of luck
3 Likes

Hey thanks for your reply. The phone does not heat, and brightness is all the way down with low power mode on. Also, I clear the cache before every flight

1 Like

Yeah, so being the avid tech geek I am, I think the reason of your issue could be contributed to two primary factors.

Phone:
Your phone is a beauty with it’s octa-core processor and MP8 Graphics card but there could be a couple factors that could cause this in which you can change. One of these are of course, being low-power mode. If you don’t have enough storage, it could also lead to some minor faults, though nothing I would suspect. Make sure you’re always connected to power if you can and try to maintain a steady WiFi connection. Most likely though, it’s just that you have too many apps open and you have to close them all before your flight. Not just a “click the home button” but a actual “quit the app”.

App:
While the app is known to have many people file the same issue as you, most of the time, it’s because they don’t have a phone capable of running such a long distance flight.

Also, can you tell me how your phone is crashing? Is it just freezing or is it something else? Lemme know! If you continue to have problems, feel free to ping me.

2 Likes

Hey thanks for your great reply. So, while I am flying there is no other application running except sometimes Infinite Flight Assistant. In fact, I always reboot the phone before long flights such as this one to make sure that no apps are running. When I am flying, the phone is showing me that I have around 2.5GB RAM still available.

Also, by low power mode, I mean the low power setting within the application. The phone itself would be using it’s normal power, so it wouldn’t be on battery saver or anything. For long hauls, it’s always on charge too, and connected to a very good wifi connection.

The phone doesn’t freeze at all, but the app somehow quits to the homescreen. It’s as though a ghost pressed the home button. Although when I try to access the app again, it starts again from the main menu, so effectively ending the flight

Is it giving you the “closing app” animation (usually the animation is the app vanishing to the homescreen) or does it freeze then quit the app?

1 Like

It just literally goes to the home screen and locks the phone. Like someone pressed the home button and then the power button. Obviously no one did. It doesn’t freeze at all.

I’ve experienced this as well how ever was on doing NZAA - KLAX ma .82 fl340 in the a380. I do this route often but only experienced the app closing twice

1 Like

I’ve had it three times in a row now, which is ridiculous. I’ve never had a problem before Tuesday. And nothing has changed since Tuesday for me to think that it is the cause for all this.

1 Like

So there’s no signs of overheating or any extreme stress on the phone?

1 Like

No, not at all. It’s so weird :(

Have you tried a good 'ol fashioned restart?

1 Like

I have, both hard and soft restarts. In fact, I do a soft restart of the device, and clear scenery cache in app, before every long haul flight

How about a reinstall for the app?

Yeah, I did a compete uninstall and reinstall yesterday before my second attempt, still no success. I really don’t know what more I could do, and I’m wondering if maybe it’s actually a bug

Lemme check and get back to you…

1 Like

Thanks man I appreciate it!

This is a duplicate topic (doesn’t bother me though).

Have a look around in these topics as well:

1 Like

So it really is a widespread issue, I hope FDS see this as it really limits the functionality of Global if a good amount of people with supported devices cannot fly long haul

1 Like

If you read the linked topics from @Jeno_Farkas above, you will discover it’s not quite that simple I’m afraid.

1 Like