App Crashing After Temporarily Leaving It

Hello friends, I have discovered a reproducible bug. The game will crash if the following steps are taken:

  1. Open Infinite Flight
  2. Select any airport and any aircraft
  3. Press “Fly”
  4. Once it loads and you reach the “touch screen to calibrate” screen, exit out of the app, and mess around your device for a minute or two.
  5. Go back into Infinite Flight and tap the screen
  6. Attempt to change the camera view
  7. Observe the crash

This was discovered after I attempted to review a flight before I spawned in. I believe this should be fixed because it’s quite annoying to have your app crash for simply leaving it for a couple of seconds. If it doesn’t seem to be working for you folks, I’ll post a video showing my issue.

Device: iPad Air 2
Infinite Flight Version: 17.12.2
iOS Version: 11.2.5

Apologies if this is a known bug.

This has happen to me a few times, it always helps me to restart the device. Also, make sure your internet connection is alright. I’m not really sure if they can do anything, but if they can they have probably been working on this lately.

Restart attempted, same result. Internet connection is stable.

This isn’t a bug, you aren’t supposed to exit IF during a flight at all. It causes crashes like you’ve described and also causes you to appear as a white ‘Unknown’ to ATC, because of which they won’t be able to respond to any of your requests. Also, you may interrupt the scenery streaming or your connection to the live servers.


Exiting a flight and coming back does not cause a crash on my end. It usually only happens when the steps above are done.

It still counts as exiting the app, which you’re not supposed to do on RAM intensive apps like IF.

I tried the steps nonetheless and was able to reproduce the crash on the iPhone 7.

Simple, dont leave the app.


Since you’re using ios11 you could swipe up from the bottom to access the dock, and then simply slide an app over a currently running app (in your case Infinite Flight). I review details about my flight often and the multitasking feature that came with ios11 is quite useful.

The point isn’t that there is no other way to access apps, it’s that the game is crashing when it isn’t supposed to.

I see your point, but it’s a “work around” to your problem to prevent it from crashing. Like some others have mentioned before, a solution would simply be: don’t exit the app, or either exit the app before starting your flight.

That’s about all I know,

This is very knowledgeable to answers for support topics! I hope this can help future threads

1 Like