App crashed on final approach

So I was just doing a flight from CVG-LAX on the casual server. I was on final approach, got the gear down and then the app just exited. My device was not overheating and this has happened numerous times before on medium to long haul flights exceeding 4 hours. Been trying to figure out what’s wrong for a few of months now. App and iPad are up to date as well.

Any bit of advice or referral to someone who can help would be greatly appreciated. Hopefully this gets fixed soon.


Hey Jack,

Crashes cannot be avoided inevitably, but there are ways to limit your chances of crashing

  • Turn off anti aliasing

  • Turn down all graphic settings to medium-low (depends on how your device can run it)

  • Turn settings down on aircraft count.

Hope this helps. Rye :)

Hey, @Jack_Oliver

Unfortunately, you are not the only one experiencing this issue. There are numerous topics similar to yours and staff are currently investigating to solve this problem.

For now, what you should try doing (to try to fix it) is restarting your device before every flight, clearing scenery cache on your Infinite flight settings, and setting rendering quality to medium or low.

Hopefully, this issue is solved soon.


Tried all those tactics for my ICN-JFK flight. No issues up until the final approach when it crashed and exited the app again.

1 Like

Check your storage and lower the graphics. This also happened to me but the fixes are only temporary.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.