App Crash and replay file issues

Device: Samsung Galaxy A51
Operating system: Android

After landing and while taxing to the gate in Atlanta, when I came closer to the gate the system warned me to maintain a safe distance with the airplane adjacent to me. As soon as I tapped to dismiss that warning the app crashed. After that, I wanted to review replay files so I reopened the app. After reopening, I got an option to resume the flight. I tried resuming that flight once. After resuming, it directed me to a position where I was 40 minutes before completion of my flight. Since, I no longer wanted to continue with the flight I ended the flight and tried to play the replay file stored. The replay file does not show the complete flight activity i did. Landing part is missing from the replay file. Now, when i try to reopen the app, still I am getting an option to continue with the flight.

Therefore, i would like to request IF support team to look into this issue and provide me necessary help.

2 Likes

Hi!

Sorry to hear you’re experiencing issues.

Let’s break it down a bit, because it seems there are three different things going on.

  1. The app crashes when you dismissed the warning message.
    I haven’t seen other reports of crashes on Android when dismissing the warning message, so this could be a one-off.
    I’ll do some testing just to be sure.
    In case of an app crash, a report is sent automatically.
    The process of finding and fixing issues that lead to an app crash is ongoing.

  2. You were not expecting Flight Resume to be available.
    This is actually intended behavior after an app crash. 😉
    Please see the linked post below.

  3. A potentially corrupt replay file
    This is a know issue, especially after een app crash, that is being investigated.
    Please see the same linked post:

1 Like

I assume that when you resume the flight you’ve lost all progress you’ve done after the unavailability of the function (basically when one of the condition to run flight resume no longer applies example under FL280)… maybe it was coded like that.

That is a good question.
I’m not sure, to be honest.
Let me try to find that out. 🙂

I’m having the same issues with IOS. I did 3 flights and only one replay was recorded and I was connected to ATC on all 3 flights. The app is crashing like crazy when I go back to attempt to replay the last two flights.

During a flight, the app keeps track of flight time, landings and XP and those stats are sent to the server at certain intervals.
That doesn’t stop when the flight is no longer being saved for Flight Resume.
When Flight Resume is available after an app crash, it will count as a separate flight, with its own flight time, landings and XP.
So nothing will be subtracted from the stats earned for the original flight. 🙂

1 Like

same problem😬

Which is?
Please be specific.
I mentioned 3 things.

And which device and OS are you using?

You state the last two flights haven’t been recorded.
So how can you attempt to replay them?

When you meant to say that the replay files for the last two flights aren’t working, then that’s probably the known issue of replay files getting corrupted.
This issue is being investigated.

Sorry let me clarify. So all 3 flight recorded but the replay for the first flight will actually play. With the last two flights, they recorded but I don’t have the ability to fast forward or rewind the replay. I literally have to keep tapping the 10 second button at the bottom of the screen to screen my progress within the replay. If I continue to tap the 10 second button (while in replay mode) halfway through flight eventually the app crashes.

So what you are now saying is that the app crashes while playing a corrupt replay file.
That is a totally different issue entirely and has nothing to do with this topic. 😉
It’s being investigated.

Nonetheless, it’s still a replay issue so I thought I was in the right thread. Thanks for investigating 😉

Hello,
Yes, these three listed things happened with me. I would like to share an incident other than the incident listed as first point in your comment. While I was arriving in Melbourne when I reached near to the gate I got a similar warning message to maintain gap with the adjacent airplane. At that time I successfully dismissed that message from the screen but as soon as I opened map the app crashed. Both incidents (one listed and other mentioned here) are the only two incidents of app crash I faced till date. Furthermore, During Melbourne incident I didn’t get an option similar to Atlanta one, that is, to resume my flight.

And regarding replay file issues, other than these incidents, i have one last incident to share. I did a flight from London Luton to Oslo. During the flight I didn’t faced any issues. Everything was running smooth. But, when i played its replay file only half of the flight was visible. I am attaching the replay file of that flight for your reference.

Link to replay file:

Thanks for the additional information.

The replay seems to have become corrupt.
That is a known issue which is being investigated.
See earlier shared link.

I’d like to keep Flight Resume not being available separate, so if that happens again, please create a new topic. 🙂

As for te app crashing after landing, like stated earlier, in case of an app crash, a report is sent automatically.

It seems that it could be a coincidence that it happened when dismissing a message, because the other time it happened when opening the map.

The process of finding and fixing issues that lead to an app crash is ongoing and you can expect fixes in future updates. 🙂

1 Like