Another bug, long-haul flights not allowed


#23

Have you tried removing and adding again the time to the destination in the lower flight status bar? This can solve


#24

Is that what could make the app crash around 3 hours flight time?

Despite all my efforts, I didn’t make it over 3 hours.
Phone cache (from recovery menu), app cache, scenery cache cleared, all settings turned down, etc. Still the same 2h 42min. I’ll try removing what @Flight_Mobile suggested and see how it goes. Back in 3 hours! 😂


#25

Unfortunately, the suggestion by @Flight_Mobile didn’t work, the app crashed to home after 2 hours and 59 mins of flight time.

All my trials so far can bee seen below:

@IconicUndead230 what version of android do you have?


#26

Same problem, app always closing around 2h 30mins of flying time!


#27

So, can we all conclude that this is a bug?


#28

Im using android 8.0, the latest one


#29

I’m guessing there is something not right.

However, it is worth to mention that as you can see on my log, I was able to fly over 4 hours when I was continuously monitoring the flight (touching the screen and therefore taking it out from Low Power Mode).

This issue only happens (to me) when I leave my phone running without touching it, regardless the graphic settings (including AA) and the airplane count.

I’m pretty sure the devs will look into this!


#30

Thanks a lot dude, you are my greatest help here man


#31

To who ever who tried to flag me down, ur just being unhelpful and useless.


#32

I did a couple of runs with different settings, but with the same results so far. I’ll let you and all the others here know if I find a solution!


#33

Thanks dude, much appreciated


#34

@IconicUndead230 @Cooper

Hello guys, any luck so far?

I just had a flight recently, which logged 6 hours and 32 mins, after 7 unsuccessful attempts. :D

So, I might have found a solution:

  • Locate an app (system process) called Android System Webview on your devices and FORCE STOP it.
How?
  • Go to Settings > Apps. (menu layout might be different based on your manufacturer’s UI, I found this on my phone in Settings > Apps > Apps.)

  • Most likely in the top right corner you’ll find a gear or 3 dots. Tap on it and choose Show System Processes.

  • If you have a search box in your app list, type in Webview (or scroll down in the app list until you find it.

  • Tap on Android System Webview. This leads to the app’s App Info page.

  • Tap on Force Stop

  • Reboot your device.
  • Check if Android System Webview process restarted after reboot or not (it did remain stopped on my phone even after several reboots).
  • Launch Infinite Flight and plan a long haul flight
  • please report back whether it worked for you or not (including your full device name/manufacturer and android build number)
  • In case it did, happy days and happy flying :D

I really hope that this will work for you as well, so let me know as soon as possible! :D


#35

I have had no luck yet, still crashing. I am playing on my IPhone and had been fine until the recent issues.

I had recently updated the phone iOS and am pretty sure the glitch in the app started around then too - but that obviously wouldn’t affect you guys using Android.


#36

Sorry for tagging you, I missed that you are not on android.

Other option for you then:

Uninstall, reboot your device, then reinstall.

(I left ios a while ago so I’m not sure whether in the app settings you can individually grant permissions.)

If you can, make sure IF has permission to access storage.

I haven’t included this in my solution as I’m about to test it out on android whether this has to be granted or not. My over 6 hours flight was done with this permission granted and today I will try it out without it. I’m trying to try out as many combinations as possible to finally get to a point when we can figure out what causing the issue, as it now seems to be cross-platform…

edit:
I’ve checked it quickly on our ipad mini 2 and I couldn’t find an option to grant storage permission to IF, though it hasn’t got the latest ios. I’ll try to get it sorted (there’s no free space on it) and update it to see how it goes for me


#37

Thanks. Will a look and try the suggestions.


#38

wow, this actually worker man! finally, after so long. now currently flying from OMDB-YMML, now 4 hours into the flight. Thanks a lot dude! you have been great help. let us wait for the ios version, see whether it worked for him too.


#39

That’s very information and thank you for helping.


#40

Hey guys so no luck again last night.

Unfortunately cannot find any options for allowing permission for storage. So only tried delete reboot and reinstall again. Been playing with putting lower graphics etc… but nothing seems to help.

Hope the fix for Android allowed you to complete your flight?


#41

I’m sorry to hear that @Cooper

Yes, as I said my 8th attempt was successful with a flight from Stansted to Toronto, clocking over 6.5 hours.
I have also checked it on an ipad mini 2 and there’s no option for storage access permission and I do think it is not necessary on android anyway, hence I didn’t mention it in the solution post.

I will do some more research on the issue now, but only for ios as android seems to be solved!

Please get back to me with your device details (model) and your current iOS version.


#42

iPhone X, iOS 12.1.2.

Thanks for your help with this!