Android version for global

Can I play global with Android 7.0? when it launches for android
sorry for my english

2 Likes

Yes, Global is compatible with Android 7.0 as long as it supports OpenGL ES 3.0.

4 Likes

Yes. It will be available for 5.0 and above

2 Likes

If your android device supports OpenGL ES 3.0 then yes

2 Likes

What about android 4.4.4

No, Android 5.0 is required.

2 Likes