[Android] Sim not appearing in play store (S7 Edge)

Mine too…

Maybe they put

OpenGL = 3.0

Instead of

OpenGL >= 3.0

… It took me four hours to find something like that in a piece of my code this morning for work… rage…

1 Like

Interesting thought. But what does your Pixel have?

I don’t think it is a hardware issue; those devices should be compatible. There seem to be something funky going on with Google Play Store (though clearing the store cache seems to not solve this) or we have an issue in our apk manifest that makes Google Play believe those devices are not compatible.

@Chris_S I don’t think it is that simple (I wish). The way it works is that you specify the minimum version required and it is supposed to work for anything equal or greater.

This is the weirdest bug so far :)

1 Like

@Chris_S are you on the US Google Play Store? Was your phone bought in the US?

No, my phone was bought in CZ from official distributor channel and it is still under warranty. How I can select which Play Store I want use?

I don’t think you can (you would need to create a new account and re-buy everything). I am investigating the issue but it might take some time. Thank you for your patience.


For the record the pixel has the exact same version as my s7.

1 Like

Good. Philippe hammered our nice little theory we had going there so… lol.

I have an S7 Edge and got the update the day it was released on Android. Funny enough, I’ve been flying a ton and the only bug I have faced so far is regarding the inputting of lengthy flight plans.

I think I’ve found the source of the issue. The OP above has a kernel version of 3.18.31 which was updated on Sep 5th.

But I have the kernel version 3.18.14 which was updated on Aug 21st, which means that I don’t have the latest version (It’s worked for me excellently since day one).

Maybe it is due to that kernel version the devices are being shown as “not compatible”.

I have kernel version 3.18.14 and worked for me

exactly my point, those with the latest version can’t install it.

But we can, and we have the S7 Edge too.

Yeah, My hypothesis is that it’s currently not compatible with S7 Edge devices that have a Kernel version higher than 3.18.14 (this version works because I’m using it).

Philippe found the issue for me! FDS saves the day again!

Summary : Check that your resolution is higher than 1920x720. Samsung offers different screen modes to save on battery life.

HD 1920 x 720
FHD 1920 x 1080
WQHD 2560 x 1440

Mine was set to HD which was causing Infinite Flight to not be compatible.

The below procedures is how I fixed it on my S7 Edge. You may try something similar with your device. FDS is continuing to look into why the HD mode is showing as incompatible.

  • Go to System Settings / Display / Screen Resolution
  • Change to WQHD or FHD
  • Reboot your phone
  • Go to System Settings / Apps / Application Manager / Select Google Play Store
  • Click on Storage
  • Click on Clear Data
  • Launch chrome and go to play.google.com
  • Search for “Infinite Flight Simulator”
  • Click on “open in play store”
  • It should now show as available to Update or Install.
  • Launch Infinite Flight
  • Follow ATC rules!

Again if you are on a different version AND your OpenGL is 3.0 or higher, try adjusting your resolution and see if it makes a difference.

Caution : Running on WQHD may cause performance issues so you may need to adjust your rendering quality to low or medium.

FDS will continue to look into it more for a more permanent solution to allowing HD.

Thank you @philippe


whoa, how do you find a solution like that xD???

Well, enjoy global! FDS suprises me again…

Woohoo! Good news. Hopefully don’t have too wait too long before the update as I can’t go above 800×480 (rip) :/

Someone says “hey check the resolution” and then hmmm what if I change it. Hey it worked. Let me try the other one…

1 Like

Thank you so much Chris! You solved the problem for me too!