Altitude Inputs causing crash

His post is clear. I’ve experienced this in various stages of flight prep (planning, taxiing, holding short of runway).

In my case, when i reduce airplane count, it no longer crashes.

Might be connected to inputting altitudes for VNAV.

His post is clear, yet you interpret it like something completely random.
One very specific action is causing the app to crash, and have been on several occasions.
That is then the cause for the crash, which is why i posted about it being known.

To then suggest various performance related suggestions, without fully understanding the post or reading my highlighted one that indicates that we clearly are aware of this specifically… is causing confusion :)

Not might. In this specific case, it is :)


We both know that VNAV inputs are causing a crash, but when the crash happens probably depends on the specs of the device being used. The solution that has worked, for me, I repeat, is reducing airplane count, IF I am in a crowded airspace at the start of a flight.

We don’t know what device he’s using…

Actually, no. I’ve looked into this issue quite a lot already and knows enough to say that the performance metrics is of no relevance here. I even have crash logs to go on.

What you’re experiencing is related to available resources, while this VNAV altitude story is something completely different. I can with 99,9% certainty say that this user is on Android based on the error description.

Not trying to slap you on the wrist or anything here. Enjoying a good discussion :)


All for the best of the community of course!:)

The question then becomes what the practical solution can be while a proper fix for this is developed.It might be airplane count, changing flight duration or perhaps you might think of something completely different.

There is no practical solution unfortunately.
It’s a null situation. Like when you’re going to do something, but then forgets how to do it and just gives up. That’s basically what’s happening here :)


Shucks. Maybe the OP can manually input the waypoints without using VNAV then? Then just use the charts to descent to the proper altitudes

As long as the altitude is not altered manually in the flight plan, all should be fine

I’ve also been getting this issue, when setting my alts for a approach. The best way for me to avoid it is to do it prior to departure.

1 Like

Hope a fix comes soon. This stresses me :x

I have been experiencing this also

So what’s been changed to cause this issue? When 20.1 was first released and even after the hotfixes, I’ve not encountered this problem when changing the VNAV altitudes whilst in flight. Am I correct in IF can make changes to the platform at any time since it’s a live system? Without the need for an update to be released for any changes to be made. Can issues like this be explained in a more detailed response by the developer’s themselves, so we can understand what’s being changed and why?

I don’t believe the devs can yet explain this. If they could, I think they would. It seems like it’s a pretty complicated issue. They have to find the root of the problem and how to fix it, which could be quick or long, depending on how complex the issue really is.

I understand software has it’s problems like all technology even hardware. It just feels like we fix one issue then appears another one. I can’t see what’s going on, unless code is being changed and played with unnecessary. I know we will never have it perfect, these types of issues are really getting under my skin, first my S8 cannot run with the newly reworked 777-200ER, even on the lowest of settings, now this issue with VNAV! In my opinion, I think we need a little more insight into what the developer’s are doing behind the scenes to address issues like and what they are doing to prevent them happening in future. We never hear anything from them, especially here on the forum, I don’t care about Instagram or Facebook or whatever. Any issue that happens on IF, is reported here on the community surely? They can communicate there but not here.

Staff has replied to this topic multiple times. Additionally support is available at

Mobile application development is a complicated endeavor. You have to account for a wide range of devices with a large number of setup configuration. Once the code has been released, you run the risk of Android pushing an update or a random 3rd party library push an update that causes an issue. There is always a cat and mouse game going on.

Believe me that they want it fixed as much as you do. The issue is right now it is not happening on ALL android devices so they are hard at work to try to find the unique scenario that is causing the crash.


Thanks Chris.

I know @schyllberg has replied, he works in technical support right? So is he helping the rest of the team to find a fix?

As I said, it would just be good to know exactly what’s being done, you know a little update? Maybe an apology or something. I know thing’s like this happen, but we are paying customers, over £300 I’ve spent on this simulator in 2-3 years, issues like this should be reported, staff provide a statement of some sort, issue is looked into, then fixed. I just feel, information withheld or slow to get to us. Communication is a big thing in this situation and without that, it leads to more problems. I like to know what’s going on, I rarely use social media so I don’t check Instagram or any other platform’s really, so unless it’s on the IFC I don’t see it. As well it comes across as the members are apologising more than the developer’s do. When a support topic is created, the members rush to help and fair play to them, they apologise to that user why? It’s not their problem, it’s IF’s and it should be IF apologising not that member.

I’ll be watching for further updates,



Hey Matt! The devs, staff, and mods don’t know why this issue is occurring on some devices and not others. They don’t know how to fix it. All they know so far is that it’s an issue and they’re looking into it, as @schyllberg said above.

You have asked that

This issue has been reported, staff (@schyllberg in this case) have provided a statement (and apologized), and the issue is being looked into. And then, hopefully soon, the issue will be fixed. To me, it looks like the staff have done exactly what you’ve asked of them.

@schyllberg i think he tried inputting 0000 into the altitude of a certain waypoint. I think i did this a few times and experienced a crash.
To clarify just in case: when for ex. trying to input different altitudes for a STAR, and if i want a certain waypoint to not have an altitude asociated with it i type in 0000 and i think that that lead the game to crash in my case

Hey Ivan, if you want a waypoint to not include an altitude, tap the altitude and just press “Ok”, clearing any altitudes already inputted. Inputting 0000 won’t work.

1 Like

Can you try to reproduce this? i.e. doing this method and getting a crash every time? Please try it out and reply with your device, OS and IF version if you can succesfully crash the game following this method. Thanks!