All 3D Buildings Missing

All buildings are missing at KDCA and other 3D airports. I have the latest version of IF installed.

Hey! Are you tried to restart infinite flight? or your Device?

Yes, restarted both Infinite Flight and my iPad. The buildings are still gone.

Do you mind providing a screenshot to show what issue you’re encountering?

Yes please send photos of your issue.

Maybe try to clear your scenery cache

Sure. Here is a photo taken just now at KDCA,

Cleared scenery cache. Buildings still missing.

Okay, I don’t know any other solutions that haven’t been posted in this topic yet except for deleting and reinstalling the app, but that should be a last resort.

I hope everything fixes for you.

Have a nice day.

Just to confirm, you have 3D building density turned up?

Perhaps switching the setting will trigger something and fix the lack of buildings.

Density is turned up to High.

Maybe switch it to a lower setting and just maybe that’ll work

Tried that too. Back and forth. No luck.

If you haven’t - and you don’t find a fix - perhaps just simply start over and reinstall IF, I feel like that’s fixed many issues I’ve seen with IF in the support area

Yes, I will do that if I have to. Pain to reset everything.

The only thing I did different today was to fly Solo for a few minutes. Crashed once.

Deleted app. Downloaded and reinstalled app. Buildings back. All ok now. Thanks everyone for trying to help.

9 Likes