Airports Not loading

Thank you very much @Robin3 im doing the flight now jfk to eham hopefully all goes well I reinstalled the app let yous now 🙂🤞🏽🤞🏽🤞🏽

1 Like

happened again im so annoyed please fix this 😔 ANOTHER 7 hrs wasted 😡
As you can see it’s EHAM

1 Like

Have you tried changing the graphic settings?

1 Like

Yeah I did exactly that and nothing changed low to high and the airport didn’t spawn

Usually after set the settings to high, the app will lag a little bit after that the airport Will load again

I can always fix it by switching a few times between high and low 3d objetcts density on the graphics section. Usually works when closer to the destin airport, like, on final app whithin the localizer. Good luck!

I had the same problem as well multiple times after a Long Flight ( 17 hours ) . There is nothing what you can do during the flight. Just restart the device after your flight

Try to hit the runway… not the grass lol


I know it’s very frustrating 😖 I really hope there will be a fix for this I literally tried everything and nothing worked I’m so 🤬 about it going to give it one more chance EHAM to KJFK if it doesn’t load I’m done.
Especially after a long haul such a waste 😩

Had the same issue some minutes ago at RJTT and I also switched the graphic settings (usually this fixed the problem every time) but today it didn´t in the beginning… I think I was too far out at this point, as I was closer to the runway (like 8nm) I tried it again (switching graphic settings) and the airport loaded in… But I agree with you this should be fixed asap, even if it´s solvable (at least for me) it´s still very annoying and this bug is the game for months…

1 Like

I had it two days ago literally haven’t landed a plane in two days due to this bug. I even circled around the airport changing settings and everything I could possibly try to fix it and nothing worked. That’s 14 hrs wasted. 😠 it’s the worst as possible. Especially after 17 hrs

have you ever done anything before that bug happen?

Make the airport density low and change it back to medium or high and that should do the trick.

No liturgy done nothing.
And that didn’t work to changing my settings tried everything. Reinstalled the app to and still happened. I really hope there is a fix for this.

Flying over Manchester and no airport this is a total disaster 😖