Airports not loading after longhaul

Anybody else have a problem with airport ground textures (not just 3D airports - although I have only noticed it happening then) not loading when coming in to land? It’s happened a couple times and luckily I was on the ILS so I managed to land but was only about to see the scenery after on the replay. Super disappointing, hoping it’s not my phone (iPhone 12 pro)

5 Likes

It’s not surely not your phone, someone else have had the exact same problem today.
I tried to help him but i ran out of ideas

1 Like

try this

2 Likes

I’m having the same problem since 21.6, not just long haul either. Changing 3D object density works but it takes a few seconds, I’ve had to go around before because it didn’t load in time.

1 Like

Hey Ian!

Try clearing your scenery cache by going to Settings → General → Scroll to the bottom and hit “clear scenery cache”. Once done just restart your app and you should be back to normal.

No, don’t worry it’s not because of your phone especially since it’s very new. It just occurs when the scenery data gets downloaded to your device can get corrupted due to a poor connection to the server.

1 Like

Thanks everybody! I’ll give these solutions a shot!