Airport rendering issues and airports didn’t load

Device: IPHONE PRO MAX 128GB
Operating system: IOS

Since the last 2/3 updates I am having rendering issues at certain airports for the second time. I’m using the new. Im using the iPhone 13 pro max.

I have tried many things like clearing the scenery cache, various IF settings (graphics, fps, aircraft count etc) and I even deleted the cache data of my iPhone iOS(Safari), but I’m still have these issues.

I’d like to say that it’s comforting to know that I am not the only one who has these issues and I am pretty sure that these issues have nothing to do with my device, since my device is the newest iPhone model that currently exists.

I know that many people already posted a thread about airport rendering issues and I most definitely know that the devs are working very hard and doing their best to fix these issues, but I thought I’d mention this once more with the hope that I will get some help on how to fix this problem, probably some ways/settings that I don’t know about yet.

*in the picture you can see that i’m
approaching literally “nothing”. but it have to be RJOC İZUMO Airport. This was the second time


*And this was the first time when i was landing on OJAİ AMMAN Jordan.

Any help will be greatly appreciated.

Thanks in advance and best regards,

Batikan

1 Like

It sometimes takes a restart of the app for this to be done fully. Restart the app and you should be fine

2 Likes

This doesn’t fix the issue I’m afraid

It’s been identified in other threads that flying over/downwind of the airport causes the issue, but the way around it if you do have this in your approach, is not to view the airport on your downwind leg.

In any case they are working on a fix

1 Like

delete your scenery cashe. that should help :)


OP has already tried what you have suggested.