Airport not loading

Just came to KSFO after a 13 hour flight, had to end it on final as the runways, 3D buildings or anything wasn’t loading, just the generic scenery you’d get anywhere else. Very frustrating as I’ve practically wasted 13 hours of my life, the green/orange arrow wasn’t indicating any issues with global scenery, any ideas?

2 Likes

Try clearing your scenery cache. Settings → General → Scroll down to the bottom → Clear scenery cache

Restart the app and load back in and see if that fixes the problem.

I did, it didn’t do anything.

Did you restart the app?

I have now, yes, I’ll try it out.

1 Like

Okay, yes, that seems to have fixed it, I’m just hoping it doesn’t happen on final again. 😅

1 Like

If it does happen again just repeat the same thing here.

Will do, might interrupt my flight though…a lot.

2 Likes

It most likely will. If not that then the app would crash.

Hey! I see you’re issue has been solved, but to lower the chances of this happening in he future you should:

*Make sure you have a decent amount of storage remaining on your device
*Make sure you have strong data or wifi connection
*Make sure no big apps are running in the background during your flight
*Make sure you frequently clear your scenary cache

Good luck and hope this helped you!

-Lukas

Okay, will do! Thanks very much Lukas!

1 Like