Airport not loading/Scenery went black

I was flying into EDDF from RKSI when I noticed the airport wasn’t loading, pretty normal until you get close, so I cleared cache and continued inbound, I was on final (about 2.5nm out) and the airport still wouldn’t load (buildings, runways, taxiways, anything), then my entire scenery went pitch black. All I could see was my HUD. What is going on? I’ve never had this issue before.

Here is a screenshot

7 Likes

Have you tried changing graphic settings? What is your rendering quality set to?

Also, if you’re flying at night, change the time to day, just to verify it’s something else.

It’s always set to Medium everything, no issues.

Time was set to day so I could actually see, because night lighting is terrible.
I changed time of day and changed graphic settings, neither fixed my issue of rendering the airport scenery. Then the entire screen went black. Tried again to change time and graphic settings, nothing fixed it. Had to end the flight.

try changing the settings on the graphics. if i won’t resolve it, try clear scenery cache then. the llast thing to do is to restart the app

1 Like

Thanks for the input, but I tried all of that mid-flight on final, nothing resolved it. I cleared cache 3 times total in an attempt to get it to load in. And then my entire screen went completely black. It’s not feasible to restart my app while in mid-flight after a long haul.

Something is clearly wrong.

2 Likes

Hey! Sorry to hear.

Did you experience any connectivity issues during the session?
Is this a recurring issue for you or was this the first time?

We have noticed an increase in these reports, but need more information to work with :)

3 Likes

I did not experience any connectivity issues, had a stable connection.
@schyllberg This is the first time it’s happened to this extent. I have had airports slow to load, but few and far between, this is the first time i’ve had an airport fail to load and the entire scenery go completely black. I typically have no issues with performance, other than lag or fps loss when flying into an extremely crowded airport (completely normal).

I typically completely restart my device after every flight to help performance as well.
Thanks for taking a look into the issues.

Also having this issue.

Generally the runway is visible but everything else is missing. Sometimes it will look fine, and then change the camera and then all scenery disappears. I’m getting it intermittently, but probably about 50% of the time.

Again, have tried clearing cache which hasn’t resolved it - and have had it happen in multiple sessions, at the same airport, pre/post cache clearing.

I’ve only had this issue since the most recent update, and am on an iPad Air 2.

2 Likes

Have this issue been recurring for you?

I haven’t had this issue on infinite flight but my iPhoneXR has done this with other apps where my screen blacks out. Another thing to consider is if your running IOS 15 beta that could be a factor.

Yep - it’s a reoccurring one, for some reason I seem to have it mostly at SCCI. I can land (everything normal), switch camera view and lose all ground textures. Sometimes cycling the cameras a couple times brings it back, sometimes not.

As I say, it’s intermittent so tough to find reliably - but still happening after multiple restarts on different days with multiple clearings of the scenery cache.

I’ve also been having this issue. There is no airport, no taxiway, no runway, nothing. It’s just the satellite image that’s there.

since the latest update airports away from departure airports are not loading


Here is an example of my arrival airports KMIA

3 Likes

This happened to me yesterday at KIWA, but clearing the scenery cache and restarting the app fixed it for me.

@John_Hill @AIDAN101 - moved your post to this topic where we’re trying to keep better track of it.

1 Like

@Flyspikes - are you on iOS or Android?

I had the same exact problem last flight. In the process of landing the airport on the ground is not loading

iOS 14.8, iPad Air 2

This issue has been happening to me a lot as well. sometimes it even happens on the airport i spawn in at. sometimes clearing scenery cache fixes it but sometimes it doesn’t

This happens to me as well. I have tried all the suggestions but have not found a solution.