Airport not appearing

So I spawned at Tirana Aiport LATI and I can’t see the airport, just the satellite images. My connection is great and my device is of its last generation and I also already cleared my cache and restarted the app a hundred times, what’s happening?

2 Likes

Have you tried restarting your device?

2 Likes

yes, multiple times

Cleared scenery cache?

yup, a friend of mine suggested that but it didn’t work

Maybe I’d suggest deleting and reinstalling IF. Unless you have already done that.

How bout restarting your device

Try to restart the flight, but before you do, restart the device and re-clear scenery cache

Also see if you have enough data to load

As I mentioned earlier, yes

it didn’t work :(

wow im stupid enough to not see that lmao

Did you try clearing prior replays or delete extra clutter on the device

1 Like

yes, my device and connection data are fine

Did you do this?

1 Like

nvm guys, the sim made me look stupid again, after all I tried, it decided to work again :/ thanks for the help guys <3

1 Like

Problem solved, the topic may be locked :)

2 Likes