Airport loads in and then disappears?

I’ve known about this issue where a lot of the time airports won’t load in. It’s happened to me a few times but today I was flying into Jfk and this happened.

This first picture is a screenshot from my stream and the airport is clearly loaded in while I fly past it

And then when I’m on approach it somehow isn’t there anymore


I’ve seen some people suggest that happens if you fly downwind to a 3D airport. Maybe try that route again but don’t go downwind?


maybe try clearing your scenery cache. ive heard that helps

1 Like

ill try it again

Ive tried it a lot of times but its never worked

1 Like

that’s odd, however from what I know a lot of people have been experiencing the same issue. I just don’t know the solution to it sadly

As I mentioned here:

That makes no difference at all

oh it doesn’t? I really thought it helps with issues with things not loading

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.