Airport glitch

I was landing into EHAM from ZBAA when the runway suddenly turned pixelated. I still attempted landing but IF told me I was over speeding. I executed a go around and am currently getting vectors back to the airport.


Hey! Sorry to hear you’re having this issue.

Have you tried these steps?

1 Like

Hello again

Maybe it’s your graphic settings. Make sure to check what they are on.
I think that the settings are low, medium, and high

To add on, maybe there are apps running in the background

Second edit: I’m no tech expert

It could also be related to this topic, there’s a temporary fix as stated below:

The devs have said they’re tracking the issue:

1 Like

I tried it and it didn’t work. I just barley made it on the ground just to have ATC yell at me “ do not taxi through grass”. At that point I just gave up. No point taxiing to the gate if you can’t see anything

I had this issue with WMKK when landing. I cleared the cache of the scenery and the airport appeared, try doing the same.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.