Airplane slides all over the ground when loading in

I tried multiple times to do VFR flights in a GA aircraft tonight, and every time I would load in at an airport, my plane would nose down and slide all over the ground. A few days ago I didn’t have this problem at all. I even tried in Solo mode and STILL kept tipping over and sliding all over the ground. Is anyone else having these problems too? Is there a way to fix it?

1 Like

Hello!

Does it happen regardless of what aircraft you choose? Or is it only GA’s?

I’ve tried it with GA planes mostly. I can try a commercial jet next…

Please do and report back :)
Is it just sliding around at the same altitude or is it falling?

Oh yeah, its falling and when I look at the map the icon is sliding across the map, and my altitude is dropping like a rock. I even tried it with a commercial jet, it does the same thing.

To resolve your issue, please try the following steps:

  • Relaunch Infinite Flight (make sure you stop it from running in the background first)
  • Before starting a new flight, Go to Settings —> General —> Tap “Clear scenery cache”. It’s in the bottom.
  • Start a flight (try on Solo first)

Note: In some rare cases, the steps above isn’t enough. If that should be the case, you will have to reinstall Infinite Flight.

OMG! It worked! I cleared the cache and restarted the game and BAM, no glitch. Thank you!

2 Likes

Great to hear :)
Apparently i did my job then.

Happy landings!

5 Likes