Airplane downloads stuck at 0%/Unable to start flights


Hello there,

So I’m not sure if it’s a known issue or if it might be specific to my account or devices, but for the last couple of days every time I start a new flight be it solo or any of the live servers, any airport and any aircraft except for the 172, it just doesn’t download and it stays on the “downloading aircraft 0%” screen forever (I’ve waited up more than 1 hour, tried both Wi-Fi and mobile data, reinstalled the app multiple times, restarted my phone but nothing seems to work, it just stays there). The device I use most of the times is a Xiaomi 12T but I’ve also tried on my secondary phone, an S20 FE and the result is the same.

I’ve been an Infinite Flight user for a couple of years now and had never experienced any issue before. I would definitely appreciate any help that might be provided!

Device: Xiaomi 12T/Samsung Galaxy S20 FE
Operating system: Android 13 on both devices - MIUI Global 14.0.5/One UI 5.1

Thanks a lot for your help :)

2 Likes

You have three solutions: 1. Check if your network connection is normal, try both mobile data network and WIFI. 2. If the network connection is normal, please check whether your phone memory is enough 3. If you have tried all of the above, then I suggest you uninstall the game and reinstall it to try again.

3 Likes

This could be an issue with system memory/storage space. If you havent already, try clearing cache or deleting unwanted files/apps/photos. Then restart the app and see if it works.

Anything further is beyond my technical knowledge

2 Likes

I’m facing the sme issue and also a message pops out that says that my account is not allowed to download this (Error Code 9) see below :

Also when I check my subscription it shows like this :

I’m certain my subscription is not over otherwise how would I be able to view HAAB as an airport or select the A350-900 as an option from the aircraft list if didn’t have a valid subscription

Device : Samsung A50s

You can check your subscription here.


It is in the account section in the settings. Here you can intuitively see your subscription deadline.
According to your second picture, I think there is a problem with your network. I suggest you try again with Wi-Fi.
According to your first picture, I can give you a suggestion. You can log out of your account and log in again and try to download it. If you still have the same question, I suggest you send an email to support@infiniteflight.com.

2 Likes

Hi, I did click on the above mentioned Manage Subscription button and that is when I got the “no subscription found” prompt.
Regarding your second idea I will try it and see if it solves my issue. Thanks for the tip👍

1 Like

I have already tried both mobile data and wifi but it doesn’t make any difference, and I’ve also cleared cache and uninstalled/reinstalled the app as well. I have 200GB+ of available storage and 8GB of RAM and I had never experienced this issue before. I think I will email the support team to see if they can help further. Thanks a lot, I surely appreciate your help and guidance!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.