Aircraft wont go up

Someone help, so today I’ve paid money to play the game and I tried to takeoff but the plane didn’t go up, I’ve tried restarting the game but didn’t work, I also reinstalled the game but still didn’t work, some one help

1 Like

Try restarting your device.

Are you able to see the yoke and control surfaces move around when you tilt your device around?

Have you tried recalibrating?

1 Like

Hey There,

First of all it looks like you need to calm down. Seems by how you are texting you seem very worried. Don’t worry, this app is very trustworthy, and not a rip-off - I think I speak for most people when I say that.

As someone who has been here for a bit, I would recommend restarting your device. I know you have already mentioned that, but that’s the most concrete thing I can recommend. Besides that, check your settings, and connection settings on your device as well.

Besides that, I would recommend reaching out to schyllberg or wait for him to pull up to you because he sure will! He’s a good guy, and he is your best bet. :)


Just checking you are using a proper take off configuration, so flaps things like that

What aircraft, speed, weight, flaps are you using when trying to take off?

Please don’t @ people of the staff. If it is an issue with the app, they will reply.

On topic: I reccomend relaunching the app after a device restart. Also make sure your connection is very strong, I advise to use the simulator on a Wi-Fi instead of a cellular network. Be aware to have enough memory and don’t run any apps in the background. Another advise is to keep the lowest amount of replays (if possible) and clear your scenery cache before every flight.

1 Like

Sorry, wasn’t actually aware of that. I’ll keep it in mind. :)

1 Like

Hey mate, like the replies above there are alot of factors like aircraft, speed, weight, flaps, and etc. Can you send me the SS of the aircraft weight and also the aircraft and rotation speed u rotate at?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.