Aircraft won't download Android

All the aircraft have to be re downloaded but won’t download

Colin,

Please provide more information and details about your issue for assistance. If your aircraft simply won’t download we recommend a quick reinstall as well.

Tyler

Try restarting your device or reinstall IF. It is required to redownload all planes - even if it’s a pain!

1 Like

Hey Tyler, I try to download the aircraft and it gets all the way to a 100% but won’t finish. Stays on a 100%

Is your Internet Connection Strong?

Have you followed the previous instructions and reinstalled the app yet?

I haven’t tried that yet. I’ll uninstall the app and reinstall it. Thanks for the help.

Uninstalled and reinstalled the app still the same problem.

Still have the problem? Try restarting your device as well to see if it helps.

Yes i am also experiencing this issue on IOS.
My topic was closed but there was no solution, I can’t enjoy the scenery with a Cessna 172…

Hey Man!!

Try these:

Keep as much unused internal device memory (RAM) available. 1GB is the recommended amount
Always close other apps before opening Infinite Flight
Keep your device fresh by completely restarting device power occasionally
Disable active add or message blocking apps
Don’t install unapproved apps
Don’t modify, “Root”, or “Jailbreak” your device
Don’t install IAP unlocking apps
Ensure Text to Speech (TTS) is enabled on Android devices
Use a strong WiFi network within a relatively close proximity to your device
Unplug your modem and WiFi router for about 30 seconds, then plug them back in if online “lag” occurs
Disable Anti-Aliasing
Lower Infinite Flight graphics and performance settings