Aircraft not on ATC menu

American 45 was on my frequency, as noted by the plane being blue, and my frequency showing on the details in the upper left corner, however it did not appear on my menu to the right and I could not communicate with the plane.

He was probably out of range. This happens to me too.

But sometimes, they send a message. Then you can communicate with them


Slightly different version of a similar issue today. This plane did everything right, and I heard th audio of Turkish Airlines, but it popped up as unknown, and I had no commands in the menu in which to respond.

I’ve also had this happen but when I click on the plane they appear back on and I’m able to communicate with them.

2 Likes

I tried that, but it didn’t work. I tried from the menu, from touching the plane…even tried going to ground and back and to another plane and back. Nothing fixed it.

And it still says they are on your frequency correct? The second picture is a different bug. I used to experience this in between updates but not recently.

Same Problem (2nd one) here :



Just happened again. This time on my iPad Pro I just got today.