Aircraft control

Sometimes after taking off, the aircraft while in autopilot will shake slightly to the left and then the right. It is very annoying. It is not Wind Gusts or velocity. Thank you in advance.

There is some crosswinds

Have you checked your weather settings?

Can we see a video? When do you engage A/P? What are the winds? More information please.

Please see this on how to make a support request:

It is on live. Not sure if I can change weather.

Don’t use the autopilot to land.


Hey, @nicgorman.

The aircraft may shake because of the winds and gusts. Check your Weather settings which are in the PAUSE menu. Make sure “Wind Velocity” and “Wing Gusts” are turned off.

Although if you’re in for a challenge, try to land in those settings. Check Mark’s tutorial on how to land with Crosswinds:

1 Like

How can I post a video?

Are you on IOS or Android?

Upload the video to a video-hosting service. Such as YouTube, Vimeo and put the link here.


Make a YouTube video then post it here.
Anyway, I believe this is just because there are crosswinds, which is realistic, not a bug.
Ah, Dush beat me to it

1 Like

Ok, are you sure your activating autopilot and not APPR.

Yes. I only have this problem on the Amazon kindle. So the bug is probably on the kindle edition.

Amazon kindle version.

Yeah they have been discussing issues with the kindle for awhile.

1 Like

You may be talking about something known as turbulence. If you’re on solo, go to weather settings and reduce it or turn it off. If you’re on live, you have no option as the weather is updated in real time. It’ll eventually subside after a while or after you fly to a different location.

This is a common occurrence. For the early models., there is a timing issue where the aircraft over shoots the heading you have assigned and tries to correct itself and over corrects. This also happens with setting an altitude where the aircraft overshoots the assigned altitude and overcorrects as well. To resolve this issue and get a smooth flight first pause and calibrate your flight, then level off your aircraft and reassign your heading/altitude again. This should resolve it.

Common causes:

Weight set above MTOW
Not leveling off a manual turn before turning on AP for heading
NOt leveling off a manual climb or descent before turning on AP for an altitude

Common aircraft this affects:
747 series
A330 series


Don’t take off with heading set on the autopilot. (Or any other AP setting, actually.)


MaxSez: Suggest use the AP after you reach V2 or a positive rate is established/ achieved on launch. Disconnect AP when localized intercept is achieved unless on autoland. (If your skilled and don’t use Assistant consider setting Alt to minimums as a safeguard. ) Your wobble is most likely WX or turbine lag induced unless your hand flying and nervous LOL… PS: I only use AP in cruise or autolanding, I don’t trust the IF Autopilot, it has a tendency to lockout without warning. Overspeed violations are inevitable if your not in cockpit view
and can immediately react!


It is live, and I do not think it is a weather issue. I will look into everything that people on this thread have said, and see if it is better. Thank you for the support.