Airbus A380 update cant fly

I have been flying the airbus A380 sence ot came out and now its saying i cant fly when i updated it

Device: iPhone 14 Pro
Operating system: IOS 17
Game verision Latesed

Could you provide a screenshot of what happens?

FYI as of 24.2 - the A380 requires a Pro Subscription to fly.

1 Like

Completely forgot about that🙄 That is probably the problem here isn’t it @Aphmau ?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.