Aggressive autopilot

Device: iPad Pro 6th generation
Operating system: iPadOs 17.0.3

Hello today when I was taking off from EDDF and I turned on the autopilot for 32000 feet and 1400fpm my autopilot Aggressively moved my aircraft up and down with an AOA up to 32 degrees and stalled my aircraft

Maybe this can be fixed in a future update,


From my experience this happens when the aircraft isn’t trimmed properly - make sure that there is no coloured line in the TRIM box on the HUD.

First it would be good letting us know your plane. If it’s a light aircraft but it’s heavy, the autopilot will struggle to maintain a constant altitude. Also I would recommend setting trim to 0 degrees as it can interfere with the autopilot. Also I wouldn’t necessarily recommend climbing at a constant 1400FPM, especially if your aircraft is rather heavy.

It is better not to set a climb rate before engaging AP. It will solve the issue.
Happy flying!


Hi, have you got some tips or information about APPR to get a smooth GS and LOC interception ? Thanks

I agree. I usually lower the nose first and find a steady position. I start first with heading/LNAV, set the heading then the VS first according to where my nose was pointed then slowly increase or decrease it to the desired VS.

As someone else also said, OP, watch the trim, if there’s a colored bar present, especially if it’s wildly moving up and down, change the trim accordingly until it disappears.

1 Like

Tbh for me it always is smoothest when you are at a level altitude and the loc needle hasn’t started moving yet, if I try when I’m already established on loc then it violently rolls trying to correct just the tiniest misalignment. Usually don’t worry about it being 30° intercept or not because I find it automatically positions for a 30° intercept anyway.

Speed must be at or below 200kts, and then usually just lower it down gradually without being too drastic, and add flaps slowly or else it can get aggressive with pitch.

Usually it works a treat for me, I try to use it to make the approach easier and disconnect around 500ft, tip before calibrating, set the trim accordingly until there’s no pink bar and then disengage APPR and it won’t have any sudden jerks when you take control (in my experience anyway)

That’s my experience usually I fly widebodies so idk the intricacies of A320 or 737 family, but that should work usually.

1 Like

Thanks for advices !!

1 Like

This is common if you don’t have a sufficient amount of speed. I suggest turning ALT & VS AP on at 200kts or more after departure. You also have to have the correct trim setting as well.
(This from experience with the Md-11, so it could be completely different for other aircraft)

But isn’t it true that if the AP is turned off to begin with, any VS setting that happens to be displayed (whether you set it to some number or not) gets overwritten with the actual VS at the instant you push AP?

It sounds like too slow for your weight and altitude. Were you stable at first and later in the climb this started to happen? Or did it start right away, say near the beginning of your climb?

Do you remember your IAS at the time?

True indeed, but some pilots set several values in the AP before engaging it, which is not a good idea, particularly the climb rate. This is why I pointed to the first obvious cause of the problem.

Bro really posting a support topic every day 💀

Yes, but what I’m saying is that it doesn’t matter what value you put in for VS with AP off (it could be 8000 for example), because when you turn on AP it always replaces that VS value with the aircraft’s actual current climb rate. Unless there is something I’m not understanding?


Oh, you are right, I stand corrected!
Good day!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.