A bit frustrated

Ever since the last update, I can’t bear the amount of times the app has crashed. The map is extremely glitchy and unreadable with all the new tracks added onto it and I even downloaded the hotfix that was intended to help prevent crashes and all 3 of the flights I tried to do today were unsuccessful. When I spawn into the map, my plane has a mind of its own and the wings and other various parts disassemble and glitch around. When I’m able to move, the aircraft suddenly controls the rudders by itself and drifts where it pleases even with the engine off. I have even restarted my device several times and updated to the most recent version. Can someone please tell me what to do because I am on the verge of cancelling my subscription which I dread having to do? Disclaimer: All my settings are already on Low quality.

2 Likes

Read this post:

5 Likes

I have already done so

2 Likes

AA off?
What device do you run IF on?

Anti-Aliasing is off and I run IF off of the Samsung Galaxy Tab A 9.7 which has had no problem running it prior to the update.

Maybe this topic can help you:

1 Like

Still didn’t work. Thank you but I will try again tomorrow, I hope they fix this quickly.

1 Like

I understand your frustration. I know they are working on it, so don’t give up.

2 Likes

I really do understand your frustration. I feel almost exactly the same way. However I trust that a fix will be implemented soon, as stated by developers.

It is very frustrating, not being able to fly. I tried one flight and it was glitchy the entire time, and that gets really difficult on landing. 😬 Haven’t flown since.

I agree with the subscription issue, if it is not fixed within a period of about two months (for me), then I may have to consider canceling my sub until we have a fix.

I hope it is resolved soon!

2 Likes

10/10 solution @pilotboy


Anyway @Flying_Ryan, you tried re-installing app?

1 Like

Yes. I have tried everything that helped me in the past, no solution and its the same situation even in solo mode.

Hm, could you tell us the device you’re using. And the version?

1 Like

@Infinite_Qantas

How many years old?

1 Like

Its been here since 2016 but this device works like its new and has never troubled me especially while operating IF prior to the update.

Do you have Frame Rate Limit on or off?

I have it on and it still doesn’t do any justice to the game and gets even worse when its off.

Well, my guess is then that the update was the final nail in the coffin.
Most devices start to get problems at 3-5 years old.

Try restarting IF and try to have background apps closed too, if that really doesn’t work either than idk.
Maybe @schyllberg knows

My iPad Pro is struggling slightly with this update and a £900 product shouldn’t really be struggling so if you have an older device is gonna be causing you issues guess we know why clouds haven’t been released yet

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.