747 Sofia

I have flown to 40,000ft yet the telescope does not open. not sure if i am doing something wrong

Hello there Adam56,

A fellow community experienced this too. I’ve tagged him.

@Recxx can you confirm since you mentioned that this appeared during one of your flights and provide a screenshot so we can pass along to the devs ;)

I’m pretty sure since the C-130 update it is on the controls section where pushback and lights are under “actions” if you press it the telescope should open.

I don’t have that option

1 Like

I’ve just checked on my IF and no I don’t either… I’m sure it was that way at some point but for now your best talking to who @Levet tagged.

1 Like

This has been going on for a long time, I thought the developers already knew about this?

They’ve said they will fix it soon. It’s possible they’ve forgotten about it.

I will take it out for a spin in a bit to confirm it still is an active issue per your request… however it was not that l was specifically unable to open the telescope… rather that there was nothing visible on the control panel display for it that gave me the option to open it… that said l will send my screenshot(s) to the previous email address you provided for me !!!

It’s still not working.

After the update before global you no longer needed to be at 40K to open the telescope…as long as you were off the ground you could do it… but l intend to do a performance test soon to verify that aspect as well !!!

I’m flying it right now there is no option for the telescope

I just tested it and no telescope well above FL400

1 Like

Roger… but there are still telescope view options in that selection area !!!

Take a screenshot of the control panel area where the telescope opening button used to be !!!

Okay. I’ve already ended the flight but I checked that all through the flight, no option was ever displayed.

Update:

@Cameron didn’t forget about this and will investigate further. Some things take time and the team has been hard at work for us. He’ll update us as soon as he can. Sorry for the inconvenience! Kind Regards, Chris

5 Likes

I cannot send a pic directly to this thread… but you can… just take a snapshot of the panel with the light switches on it… the telescope open/close was below that !!!


Just tried again but still no auto opening or button to open it

2 Likes