737-800 elevator suck pitching up

I’m doing a flight from SKBO to MPTO and during my climb my 737-800 pitch up dramatically and I stalled but recovered in time. I noticed that when I calibrated my device the elevators were still pitching up. I’ve been able to control this using autopilot but I don’t know what I’ll do on my landing.

1 Like

Is your trim at 0%?

Yes it’s at 0%

Can you restart your app if able?

My ETE is 29:30 so I don’t really want to restart the whole flight

umm, try calibrated again? Had this problem once and I did calibrate couple time and it worked.

Still nothing :(

Try 5 time? If not, then there nothing I can do about this . :(

Yep think this calls for rework time

1 Like

Try calibrating again BUT this time pitch your iPad down around 60%. Of course you won’t be putting the plane in a dive so I recommend putting the plane on autopilot.

Thanks this helped alot

1 Like

No problem! Happy to help!

Fun Fact: This has happened to me before as well! It can get really annoying! XD

Glad to hear that it worked! :D