22.8 Update Problem

I’m not sure if it’s me, but I cannot access the Infinite flight app, some help would be great, and tips on how to fix it would be amazing.



More details would help us help you. Does the app just not open when you launch it, or does it show any error code?

Also, on what device does it happen?

Hello I think i have the same problem, It’s just staying on the loading screen the whole time without going to the home screen like this

To add on my internet connection is good so im not sure what’s happening.


I believe this is a known problem. Just uninstalling and reinstalling the app should help^^

1 Like

Thank you very much that worked

What if i lose all my replays and planes

If you sign back in, you will still have your planes because you own a subscription. If you bought aircraft before global, they’ll still be there once you resign. Replays will be deleted.

Thank you very much i really appreciate it

You can export all your replays and put them in somewhere like your files. After reinstalling, you can import back the replays.

How do I do that on a iPad ?

Same thing. Long press on the app until you see a small (x). Tap on it and press uninstall. Then, go to the App Store and reinstall the app. Should be the same for all IOS devices.

Are you talking about the uninstalling part or the storing files part?

Storing files

Exporting replays in ios
In IF, open the Replays tab
Select the replay you wish to export (I think you can only do one replay at a time)
Select Share (bottom menu)
Select Save to Files
Choose a location to save it (On My iPad…etc).
(Create a new folder for your replays if you wish)
Tap Save

Ok thanks .

I’ve got common and similar issues too! Just a few minutes ago I tapped on an active airport on the home screen to read the D-ATIS and the app just crashed. I was thrown out of IF back to my iPad home screen. That also happens sometimes when I’m about to spawn at an airport. As soon as I tap on “FLY”, the app just crashes and I get back to my iPad home screen

Also I have noticed quite a lot of frame rate disruptions and a few days ago I opened the app and it just kept loading and loading but didn’t open up

It worked but i have to download all the planes again, thank you much appreciated

1 Like

I uninstalled and reinstalled the app and it worked but a day later the problem is back

Unfortunately I believe the problem hasn’t been fixed and the best way is to uninstall and reinstall. Sorry for the inconvenience.

What device do you use?